Why do I have to update Blog2Social to 4.7?

Blog2Social
2018-03-22 10:55

Due to major changes in Twitter’s terms of service (TOS), we had to adapt Blog2Social to the new Twitter automation rules, which requires a mandatory update of all social media automation tools. Please update Blog2Social to the latest version 4.7.

To update Blog2Social, go to “plugins” in your WordPress backend. Look for the plugin “Blog2Social” in your plugin list. It will tell you that there is a new version of Blog2Social. To update, just click “update now”.

>>Learn more about all the updates in version 4.7

>> Learn more about the Twitter terms of service update February 2018 + answers common questions

Test Blog2Social 30 days free of charge

4.7, mandatory, Update

Average rating: 0 (0 Votes)

You cannot comment on this entry